Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
18.11.2017, 16:43:42
 
Начало Помощь Поиск Войти Регистрация
Новости: Форум обновлен

+  Форум АО "ВЗЛЕТ"
|-+  Автоматизация и диспетчеризация
| |-+  Взлет СП4
| | |-+  Взлет СП4 и порт RS232
0 Пользователей и 1 Гость смотрят эту тему. « предыдущая тема следующая тема »
Страниц: [1] Печать
Автор Тема: Взлет СП4 и порт RS232  (Прочитано 2493 раз)
fdn
Пользователь
**

Харизма: 0
Офлайн Офлайн

Сообщений: 19


« : 16.12.2015, 04:15:53 »

USB порт компьютера через преобразователь USB->RS232 (model STLab U-224), далее полный null-modem, подключен к COM порту тепловычислителя ТСРВ-033.
"Универсальный просмотрщик" нормально работает, в том числе считывает архивы.

Параметры настройки COM порта в "Универсальном просмотрщике":
cкорость - 4800;
управление потоком- нет;
ожидание ответа - 1500ms;
байтовый таймаут - 0ms;
число попыток запроса -1.

Настройка COM порта ТСРВ-033:
cкорость - 4800;
управление потоком- нет;
задержка ответа - 50ms;
байтовый интервал - 2ms;
тип соединения - прямое.

Программа Взлет СП4 не находит прибор ТСРВ-033.
Появляется сообщение: "Прибор или транспорт недоступен".
Параметры настройки COM порта во " Взлет СП4":
cкорость - 4800;
тип соединения - прямое;
таймаут - 1s.

Меняю  USB->RS232 (model STLab U-224) с null-modem'ом на другой USB->RS232 (BOLID), который имеет только два сигнала TX и RX, без null-modem.
Программа Взлет СП4 находит прибор ТСРВ-033 и все архивы можно снять.

Что-то там феерично написано во Взлет СП4 ?
Что нужно настроить, чтобы исправить ситуация с USB->RS232 (model STLab U-224) ?


Записан
Дмитрий Пархоменко
Global Moderator
*****

Харизма: 18
Офлайн Офлайн

Сообщений: 692



« Ответ #1 : 16.12.2015, 10:47:25 »

Здравствуйте!

С учетом посредника в виде конвертера USB-COM и скорости в 4800, 1 секундный тайм-аут может быть маловат, попробуйте хотя бы с 3-х секундным, который ставится по умолчанию.

Последняя ли у Вас версия Взлет СП4 - 4.0.7.1 ?
Если нет, обязательно обновите комплекс и повторите попытку, т.к. уже был решен ряд проблем с конвертерами.

Также Вы можете добавить описание прибора самостоятельно, без процедуры поиска и попробовать произвести опрос.

Из общих возможных причин:
- "криво" установились драйвера в Windows (мы такое уже наблюдали у конвертеров с чипом Prolific, Ваш STLab U-224 как раз на таком чипе);
- прозвоните тестером контакты 2, 3 и 5, убедитесь что Ваш кабель действительно нуль-модемный, что 2 и 3 перекрещены (бывает такое, что под видом нуль-модемных продают прямые кабеля).
Записан
I_m
Наш человек
***

Харизма: 4
Офлайн Офлайн

Сообщений: 226


« Ответ #2 : 16.12.2015, 10:50:54 »

А разве null modem не предполагает перекрестного соединения?
Т.е.
RxD <-> TxD
TxD <-> RxD

Может в этом дело?
Записан
fdn
Пользователь
**

Харизма: 0
Офлайн Офлайн

Сообщений: 19


« Ответ #3 : 16.12.2015, 11:10:16 »

А разве null modem не предполагает перекрестного соединения?
Т.е.
RxD <-> TxD
TxD <-> RxD

Может в этом дело?

На физическом уровне соединение работает и для USB->RS232 (model STLab U-224), и для USB->RS232 (BOLID), в котором только два сигнала: TxD , RxD.
Схема соединения стандартная : (компьютер USB-RS232) DTE <-> DCE (null modem) <-> DTE (ТСРВ-033) .

Почему программа Взлет СП4 не работает, когда  установлен USB->RS232 (model STLab U-224)  со всеми (почти со всем) сигналами RS232 ?
Почему программа Взлет СП4 работает, когда  установлен USB->RS232 (BOLID)  только с двумя сигналами TxD , RxD ?
Почему программа "Универсальный просмотрщик" работает, когда  установлен USB->RS232 (model STLab U-224)  со всеми (почти со всем) сигналами RS232 ?
Записан
fdn
Пользователь
**

Харизма: 0
Офлайн Офлайн

Сообщений: 19


« Ответ #4 : 16.12.2015, 11:40:28 »


С учетом посредника в виде конвертера USB-COM и скорости в 4800, 1 секундный тайм-аут может быть маловат, попробуйте хотя бы с 3-х секундным, который ставится по умолчанию.

Не помогло.

Последняя ли у Вас версия Взлет СП4 - 4.0.7.1 ?
Если нет, обязательно обновите комплекс и повторите попытку, т.к. уже был решен ряд проблем с конвертерами.

Помогла замена Взлет СП4 - 4.0.3 на Взлет СП4 - 4.0.7.1


Из общих возможных причин:
- "криво" установились драйвера в Windows (мы такое уже наблюдали у конвертеров с чипом Prolific, Ваш STLab U-224 как раз на таком чипе);
- прозвоните тестером контакты 2, 3 и 5, убедитесь что Ваш кабель действительно нуль-модемный, что 2 и 3 перекрещены (бывает такое, что под видом нуль-модемных продают прямые кабеля).

STLab U-224 на правильном Prolific . Проходил эту проблему несколько лет назад.
Драйвера в Windows  работают и провода в  нуль-модеме распаяны правильно, т.к. всё проверялось терминальной программой
по схеме (компьютер USB-RS232  STLab U-224) DTE <-> DCE (null modem) <-> DTE (COM порт компьютер)

Помогла замена Взлет СП4 - 4.0.3 на Взлет СП4 - 4.0.7.1 .  Вся проблема была в этом программном обеспечении.
Записан
Дмитрий Пархоменко
Global Moderator
*****

Харизма: 18
Офлайн Офлайн

Сообщений: 692



« Ответ #5 : 16.12.2015, 11:49:28 »

Рад был помочь.
Записан
Страниц: [1] Печать 
« предыдущая тема следующая тема »
Перейти в:  


Войти

© 1990—2016, АО «Взлет».
Все права защищены.
Контактная информация
Powered by SMF 1.1.13 | SMF © 2006-2011, Simple Machines LLC
Материалы, размещенные на сайте, охраняются законодательством об авторском праве. Перепечатка материалов допускается только со ссылкой на сайт.