1

1. Назначение адаптера

Адаптер сигналов “Взлет АС” исполнения “Адаптер сетевых протоколов АСПВ-010” является функциональным и конструктивным аналогом изделия Взлет АСП. Поэтому на него полностью распространяются приводимое ниже сведения, касающиеся адаптера Взлет АСП.

Адаптер АСПВ-010 обеспечивает подключение одиночных приборов и шины Взлет к компьютеру, телефонному и радиомодему, а также их подключение к маркерной шине.


2

2. Настройка режимов эксплуатации

Настройка адаптера заключается в выборе пользователем одного из режимов эксплуатации и задании параметров, определяющих работу адаптера в выбранном режиме.

На корпусе адаптера размещены два разъема DB9, розетка и вилка. К розетке подключаются одиночные приборы и шина Взлет. К вилке подключается связное оборудование или маркерная шина, а также в ряде случаев шина Взлет. Каждый из разъемов содержит цепи интерфейсов RS-232 и RS-485. Используемые интерфейсы и разъемы определяются выбранным режимом эксплуатации. Соответствующие схемы соединений приводятся при описании каждого типа подключения.

Режимы 2*,3* и 4* не поддерживались в начальных версиях резидентного программного обеспечения адаптера. Опыт его применения показал, что для обеспечения большей эксплуатационной надежности целесообразно осуществлять гальваническое разделение на интерфейсе RS-485. Новые режимы введены для замены соответственно режимов 2,3 и 4, которые не имеют гальванического разделения. В функциональном отношении новые режимы являются полными аналогами прежних.

При первоначальной настройке адаптера рекомендуется выбирать новые режимы. Для ранее выпущенных устройств целесообразно произвести обновление резидентного программного обеспечения и изменить схему подключения адаптера к внешнему оборудованию.

Выбор режима эксплуатации и задание его параметров производятся в настроечном состоянии. Для перехода в него адаптер подключается к COM-порту компьютера по следующей схеме:

После соединения с компьютером включается питание адаптера и по наличию перемычки 1 - 6 его программа определяет, что необходимо перейти в состояние настройки. Пользователь запускает программу Asetup. Она поставляется совместно с адаптером на носителе в виде упакованного архивного файла, при запуске которого происходит автоматическая распаковка и установка программы на компьютере. После установки на рабочий стол помещается ярлычок программы.

Окно запущенной программы Asetup имеет меню для указания COM-порта, к которому подключен настраиваемый адаптер. Для каждого режима в окне выделены вкладки. Параметры текущего эксплуатационного режима можно получить, нажав кнопку Чтение.

Для перенастройки адаптера выбирается соответствующая вкладка, заполняются ее поля, и затем нажимается кнопка Запись. По умолчанию во всех полях установлены оптимальные значения, но для конкретных условий эксплуатации может понадобиться их изменение. Диапазоны возможных значений поясняются в разделах, посвященных конкретным типам подключения. Выбранные значения параметров сохраняются в неразрушаемой памяти адаптера.

На лицевой панели адаптера имеется два светодиода. Один указывает на наличие питающего напряжения. Включение другого светодиода происходит на время передачи информации по любому из направлений. Он позволяет судить об интенсивности обмена через адаптер. При эксплуатации светодиод включается и горит постоянно, если обнаружено разрушение настроечных данных. В этой ситуации обмен через адаптер прекращается. Светодиод горит постоянно и в настроечном режиме, когда адаптер обнаружил технологическую перемычку. Поэтому после настройки следует выключить адаптер, снять технологическую перемычку, затем снова включить и убедиться, что светодиод обмена находится в выключенном состоянии.


1

2.1 Подключение шины Взлет к маркерной шине

Шина с маркерным доступом применяется для объединения приборов ЗАО НПФ “Логика” и их подключения к компьютеру. При этом используются адаптеры АПС69 или АПС69М1,2. Схемы подключения этих адаптеров к компьютеру приводятся в их сопроводительной документации.

Адаптер АСПВ-010 позволяет подключить шину Взлет к маркерной шине в качестве коллективного абонента. К маркерной шине АСПВ-010 присоединяется со стороны разъема вилка. С этой стороны он работает как один из приборов маркерной шины. Поэтому при его настройке необходимо ввести используемые адреса и скорость обмена на маркерной шине. Выбор значений подробно описан в разделе 8.2.7 документа [1].

В случае сбойных ответов или отсутствия ответа от шины Взлет адаптер может самостоятельно повторять запросы. Алгоритм работы определяется двумя устанавливаемыми при его настройке параметрами: Ожидание ответа и Повторные запросы. Не равный нулю Межбайтовый интервал задается, если выбранная для обмена на шине скорость выше 4800 бит в секунду и необходимость этого оговаривается в особенностях подключения хотя бы одного из приборов на шине. Эти сведения содержатся в документе [1].

Ниже приведена схема включения адаптера в этом режиме.


2

2.2 Подключение шины Взлет к компьютеру

Адаптер является буферизованным устройством. Направляемый в сторону шины запрос и ее ответ предварительно накапливаются в адаптере. Поэтому скорость на стороне разъема розетка, обращенного к шине Взлет, может отличаться от скорости со стороны разъема вилка.

В случае сбойных ответов или отсутствия ответа от шины адаптер может самостоятельно повторять запросы. Алгоритм работы определяется двумя устанавливаемыми при его настройке параметрами: Ожидание ответа и Повторные запросы. Не равный нулю Межбайтовый интервал задается, если выбранная для обмена на шине скорость выше 4800 бит в секунду и необходимость этого оговаривается в особенностях подключения хотя бы одного из приборов на шине. Эти сведения содержатся в документе [1].

Адаптер устанавливается на стороне компьютера и подключается к его COM-порту. Компьютер может иметь 9-ти или 25-ти контактный разъем. Возможные схемы соединений приведены ниже. Первая схема соответствует режиму 2, а вторая – режиму 2*, обеспечивающему гальваническое разделение. Оба режима аналогичны по функциям, но рекомендуемый режим 2* не поддерживался в ранних версиях резидентного программного обеспечения адаптера. Такие устройства целесообразно обновить, как описано в разделе 3.


2

2.3 Подключение шины Взлет к телефонному модему

Адаптер устанавливается на стороне шинного модема и подключается к нему стандартным модемным кабелем или кабелем по приведенной ниже схеме. Модем может иметь 9-ти или 25-ти контактный разъем.

Модем должен быть предварительно настроен с помощью программы Msetup, которая размещена для свободной загрузки на сайте ЗАО “Взлет” по адресу http://www.vzljot.ru . Модем настраивается также как для работы с одиночным прибором, но в качестве прибора в меню выбирается Взлет АСП. Число звонков до автоответа модема устанавливается равным нулю. Модем в этом случае работает без автоответа. Ответом управляет адаптер, которому и задается требуемое число звонков до ответа.

В случае сбойных ответов или отсутствия ответа от шины адаптер может самостоятельно повторять запросы. Алгоритм работы определяется двумя устанавливаемыми при его настройке параметрами: Ожидание ответа и Повторные запросы. Не равный нулю Межбайтовый интервал задается, если выбранная для обмена на шине скорость выше 4800 бит в секунду и необходимость этого оговаривается в особенностях подключения хотя бы одного из приборов на шине. Эти сведения содержатся в документе [1].

Возможные схемы соединений с приборами приведены ниже. Первая схема соответствует режиму 3, а вторая – режиму 3*, обеспечивающему гальваническое разделение. Оба режима аналогичны по функциям, но рекомендуемый режим 3* не поддерживался в ранних версиях резидентного программного обеспечения адаптера. Такие устройства целесообразно обновить, как описано в разделе 3.

Настройка адаптера в режиме 3 позволяет указать, что реально на шине работает один прибор и обмен с ним следует вести через интерфейс RS-232. Обычно одиночный прибор подключаются к модему непосредственно, без адаптера. Однако если модем нельзя настроить для работы в прозрачном режиме (например, сотовый модем), а в приборе используется протокол с временнОй синхронизацией (например, ТСРВ-020), то решением может быть адаптер, работающий в режиме 3. В этом случае используется следующая схема:

Если используется сотовый модем и строится охранная система на основе SMS-сообщений, то дополнительные настройки выполняются на бланке, который вызывается кнопкой SMS. Здесь пользователь может указать до двух абонентов, к которым должны направляться SMS-сообщения, задать их текст и условия формирования. Помимо изменения уровня входных сигналов, можно потребовать, чтобы сообщение отправлялось и при включении питания адаптера. Кроме того, задаются параметры, которые будет использовать центр передачи SMS-сообщений.

Для запуска (остановки) контроля в адаптер направляются специальные SMS-сообщения. Пользователь может защитить их паролем. Пароль задается, как последовательность из шести цифр. Если на бланке настройки пароль задан, то исполняются только те приходящие сообщения-команды, в которых имеется этот пароль. Если пароль не задан, то и в управляющее сообщение его не требуется включать.

После задания всех необходимых настроек кнопкой Ввод окно закрывается. Затем, если необходимо, задаются другие параметры режима 3, и кнопкой Запись все данные переносятся в адаптер.

Указанные при настройке телефоны могут адресовать как сотовые трубки, так и сотовый модем, подключенный к компьютеру. В последнем случае прием сообщений и отправка команд осуществляется приложением Spguard. Во время установки комплекса Взлет СП оно помещается в его рабочую папку. Подробно работа приложения описана в п.5.5.3 документа [1].

Сотовая трубка принимает охранные сообщения, как обычные SMS-сообщения. Управляющие сообщения, направляемые в адаптер, подготавливаются в виде последовательности из семи цифр KPPPPPP, где К указывает команду, а последовательность РРРРРР должна совпадать с паролем, если он используется. Если пароль не используется, последовательность может быть опущена. Команда К принимает значения: 0 – выключить контроль; 1 – включить контроль; 2 – сообщить состояние. Каждое управляющее сообщение адаптер АСПВ-010 подтверждает ответом из трех цифр CSS. Первая C указывает состояние контроля (0/1 – выключен/включен), а цифры SS указывают уровни соответственно первого и второго входов.


1

2.4 Подключение одиночного прибора к радиомодему

Прибор подключается к радиомодему через адаптер АСПВ-010, работающий в режиме 5. Для связи прибора и адаптера используется интерфейс RS-232. Ниже приведена схема подключения адаптера к модему и прибору.

При радиообмене компьютер обращается к прибору через адаптер, используя Позывные адаптера. Один компьютер может взаимодействовать с несколькими приборами. В этом случае каждый адаптер должен иметь уникальные позывные. Позывные представляют собой цифровую последовательность, включающую до 4-х цифр.

Между позывными и телефонным номером существует полная аналогия. В начале обмена компьютер выводит служебное сообщение, содержащее позывные. Адаптер, у которого позывные совпадают, начинает считать себя выбранным и включает прибор в радиообмен. Остальные адаптеры “наблюдают”, пытаясь выделить из этого обмена служебное сообщение с позывными. Когда передаются новые позывные, первый адаптер автоматически отключает прибор от радиообмена и начинает ждать вновь свои позывные.

В процессе радиообмена адаптер контролирует его интенсивность. Если в течение двух минут передача данных не производится, адаптер отключает прибор от радиообмена и начинает ждать свои позывные.

При настройке адаптера для разъема розетка, обращенного к прибору, может быть установлена высокая скорость обмена, т.к. это локальное подключение. Не равный нулю Межбайтовый интервал задается, если скорость выбрана выше 4800 бит в секунду, и необходимость задания интервала оговаривается в особенностях подключения прибора [1].

Та же скорость должна быть указана для приборного интерфейса RS-232. При этой настройке приборного интерфейса для одиночного прибора следует указывать адрес равный единице.

Адаптер является буферизованным устройством. Направляемый в сторону прибора запрос и его ответ предварительно накапливаются в адаптере. Поэтому скорость в радиоканале может отличаться от локальной скорости. Она задается как скорость обмена со стороны разъема вилка. Диапазон возможных значений - 1200, 2400 и 4800 бит в секунду.

Обмен в радиоканале осуществляется в полудуплексном режиме. Для передачи данных адаптер переводит в активное состояние линию RTS и выполняет Задержку передачи, необходимую для “разгона” передатчика. После этого данные передаются в канал.


2

2.5 Подключение шины Взлет к радиомодему

Данное подключение аналогично работе адаптера при радиодоступе к одиночному прибору. Пояснения, приведенные в разделе 2.5, применимы здесь, если вместо прибора подразумевать шину.

Возможные схемы соединений с приборами приведены ниже. Первая схема соответствует режиму 4, а вторая – режиму 4*, обеспечивающему гальваническое разделение. Оба режима аналогичны по функциям, но рекомендуемый режим 4* не поддерживался в ранних версиях резидентного программного обеспечения адаптера. Такие устройства целесообразно обновить, как описано в разделе 3.


1

2.6 Подключение одиночного прибора к маркерной шине

Шина с маркерным доступом применяется для объединения приборов ЗАО НПФ “Логика” и их подключения к компьютеру. При этом используются адаптеры АПС69 или АПС69М1,2. Схемы подключения этих адаптеров к компьютеру приводятся в их сопроводительной документации.

Адаптер АСПВ-010 позволяет подключить к маркерной шине прибор фирмы “Взлет”. К маркерной шине АСПВ-010 присоединяется со стороны разъема вилка. С этой стороны он работает как один из приборов маркерной шины. Поэтому при его настройке необходимо ввести используемые адреса и скорость обмена на маркерной шине. Выбор значений подробно описан в разделе 8.2.7 документа [1].

Адаптер устанавливается на стороне прибора и подключается к его интерфейсу RS-232 по следующей схеме.

Большинство приборов имеют интерфейсный разъем DB9. Исключением являются приборы MP400 и Взлет ЭР (ЭРСВ-01Х,31Х). У этих приборов цепи интерфейса выведены на клеммную колодку XT2, размещенную на плате процессора. Ниже приводится таблица соответствия между номерами контактов этой колодки и номерами контактов разъема DB9.

В случае сбойных ответов или отсутствия ответа от прибора адаптер может самостоятельно повторять запросы к прибору. Алгоритм работы определяется двумя устанавливаемыми при его настройке параметрами: Ожидание ответа и Повторные запросы. Не равный нулю Межбайтовый интервал задается, если выбранная скорость обмена выше 4800 бит в секунду и необходимость этого оговаривается в особенностях подключения данного прибора в документе [1].

Та же скорость должна быть указана для приборного интерфейса RS-232. При этой настройке приборного интерфейса для одиночного прибора следует указывать адрес равный единице.


3

3. Обновление резидентной программы

Адаптер спроектирован так, что при расширении функциональных возможностей пользователь самостоятельно может произвести его модернизацию. Для этого достаточно загрузить с сайта фирмы http://www.vzljot.ru сервисную утилиту обновления адаптера, исполнить ее, а затем, находясь в настроечном режиме нажать кнопку Обновить ПО.


4

4. Тестирование адаптера

Работоспособность адаптера проверяется с помощью трех тестов: общего теста и раздельных тестов для двух интерфейсов RS-485. Переход к ним происходит при нажатии на кнопку Тест. На экран выводится панель с кнопками для выбора конкретного теста.

Во время общего теста выполняется проверка всех цепей подключения, кроме интерфейсных цепей RS-485. Процесс запускается при нажатии на кнопку Общий тест. Тестирование выполняется в два этапа. После успешного завершения первого этапа программа предлагает установить тестовую заглушку на разъем розетка. Заглушка выполняется по следующей схеме.

После установки заглушки работу программы следует продолжить. Общий тест позволяет выявить обрыв и неправильную коммутацию внутренних цепей адаптера.

Тесты интерфейсных цепей RS-485 выполняются с помощью дополнительного преобразователя RS-232/RS-485. Может использоваться любой преобразователь, работающий в автоматическом режиме, когда не требуется внешнего управления включением/выключением передатчика RS-485. Такими являются, например, преобразователи MOXA А52, А53 или преобразователи серии ICPCON i7520.

Исходно в этих тестах адаптер подключается как для настройки по схеме:

После включения питания адаптера выбирается требуемый интерфейсный тест. На экран выводится сообщение “Ожидание соединения”. Не выключая питание адаптера, следует отстыковать от компьютера соединительный кабель. Далее адаптер подключается к освобожденному COM-порту через преобразователь RS-232/RS-485 по одной из приведенных ниже схем в соответствии с выбранным тестом. Во время подключения питание преобразователя должно быть выключено.

После подключения питание преобразователя RS-232/RS-485 следует включить, и тест автоматически продолжится.


1

Литература

1. Сеть приборов Взлет СП. Руководство пользователя.

Информация на сайте http://www.vzljot.ru